CCIE Pursuit Blog

April 6, 2008

Internetwork Expert Volume II: Lab 9 – Section 2

WAN Technologies – 8 Points

2.1 Partial Mesh

Subinterfaces on r3 and r4 – should I use ptp or ptm?  I read ahead to IGP to see if there’s anything that forces ptm, but I didn’t find anything.  Looks like I can use ptp.

Interesting Frame Relay network.

2.2 Point-to-Point

CCOnlinelabs throws a TON of DLCIs at you:

r3(config-if)#do sh frame pvc | i Serial0/1/0
PVC Statistics for interface Serial0/1/0 (Frame Relay DTE)
DLCI = 311, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 312, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 314, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 315, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 316, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 317, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 318, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 319, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 331, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 332, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 334, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 335, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 336, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 337, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 338, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0
DLCI = 339, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0

interface Serial0/1/0
 description ->FR PTP r5
 ip address 148.1.35.3 255.255.255.0
 encapsulation frame-relay
 shutdown
 no frame-relay inverse-arp IP 311
 no frame-relay inverse-arp IP 312
 no frame-relay inverse-arp IP 314
 no frame-relay inverse-arp IP 316
 no frame-relay inverse-arp IP 317
 no frame-relay inverse-arp IP 318
 no frame-relay inverse-arp IP 319
 no frame-relay inverse-arp IP 331
 no frame-relay inverse-arp IP 332
 no frame-relay inverse-arp IP 334
 no frame-relay inverse-arp IP 335
 no frame-relay inverse-arp IP 336
 no frame-relay inverse-arp IP 337
 no frame-relay inverse-arp IP 338
 no frame-relay inverse-arp IP 339
end

Whew!!!  🙂

 2.3 Point-to-Point

Very easy task.

2.4 Network Redundancy

If line protocol of the Frame-Relay subinterface goes down, then fire up a backup serial interface. 

In this case the subint goes down (but not the phys int) when we shut s0/0/0 on r1:

Serial0/0/0                unassigned      YES unset  up                    up
Serial0/0/0.401            148.1.0.4       YES manual down                  down

So we don’t need to worry about FREEK.

ARRGH!!! I have to use 12.3 documentation because Cisco has royally fucked up the 12.4 docs.

backup interface

backup delay

backup delay {enable-delay-period | never} {disable-delay-period | never}

r4(config-subif)#backup del 0 300

First value is the delay (in seconds) in bringing up the backup, the second value is the delay in dropping the backup when the primary path returns.  (default is 0 seconds for both)

I don’t know of a way of seeing the disable delay (outside of looking at the int config) but the “show backup” command will show the number of seconds remaining on the disable delay after the primary path returns:

r4#sh backup
Primary Interface   Secondary Interface   Status
—————–   ——————-   ——
Serial0/0/0.401     Serial0/1/0           waiting to revert (290 more seconds)

Advertisements

Internetwork Expert Volume II: Lab 9 – Section 1

Bridging and Switching – 17 Points

“There are no faults in the initial configurations.”
“Do not alter the commands in the initial configurations.”

1.1 Trunking

One of the first things that you’ll notice in this lab is that there are routing protocols preconfigured.  BGP on sw1, EIGRP on sw3, and so on.  This looks like it will be an interesting lab.  🙂

I’m off to a rough start already.  The first task is a simple trunking task with the requirement of:

“For ease of administration refer to these trunks with the interface macro DOT-ONE-Q.”

I’m going to assume that “refer to” means “create a macro that completes this task.”  This is another “ask the proctor” moment.

Configuring Smartports Macros

The totality of my experience with switchport macros lies with creating ping scripts. 

sw1(config)#macro name DOT-ONE-Q
Enter macro commands one per line. End with the character ‘@’.
interface range fa0/13 – 15
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
@

sw1(config)#do sh run int fa0/13
interface FastEthernet0/13
end

Okay.  Let’s run this sucker:

sw1(config)#macro glob app DOT-ONE-Q
sw1(config)#do sh run int fa0/13
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate

end

Sweet!!!  Well maybe not:

sw1#sh run int fa0/14
interface FastEthernet0/14
end

For whatever reason the interface range did not take.  It only took the first interface.  Okay…there is no “minimal configuration” requirement so I took out the interface range command and explicitly configured each port:

sw1(config)#macro name DOT-ONE-Q
Enter macro commands one per line. End with the character ‘@’.
int fa0/13
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
int fa0/14
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
int fa0/15
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
@

The IE solution uses:

define interface-range DOT-ONE-Q FastEthernet0/13 – 15

but then their macro explicitly configures each interface.  So what it the purpose of the above command?

define interface-range

1.2 Trunking

Weird.  sw4 is a 3550 yet:

interface FastEthernet0/19
 switchport mode dynamic auto <-auto?

Must have been thrown on in the initial configs.

Otherwise, this was a very basic EtherChannel configuration task.

1.3 Trunking

Fun trunking task. 

“All traffic sent over these trunk links should include a 32 bit tag.”

This threw me off at first.  ISL has a 24 byte tag and Dot1q has a 4 byte tag.  What the hell is a 32 byte tag?  Reading the requirement closer, I see 32 BIT no 32 byte.  Ah…32/8 = 4 bytes = Dot1q 🙂

Of course, I missed the second important part of that requirement: ALL TRAFFIC

By default dot1q does NOT tag the native VLAN so any traffic on the native VLAN will not have a 32 bit tag. 

vlan dot1q tag native

1.4 VLAN Assignments

Argh!!!  The dreaded “minimal VLAN configuration with all switches in VTP Transparent mode from the diagram” task.  :-0

I’m getting better at this (I completed the task successfully) but I am still VERY slow.

1.5 Spanning-Tree Filtering

spanning-tree guard

1.6 Spanning-Tree

I monkeyed around with this task trying to match the STP timers required by the task.  I finally gave up and went ahead and explicitly set the timers for VLAN 68.  This cost me the points as I needed to accomplish this task with minimal configuration:

sw2(config)#span vlan 68 hell 1
sw2(config)#span vlan 68 max 7
sw2(config)#span vlan 68 for 5
sw2(config)#do sh span vlan 68

VLAN0068
  Spanning tree enabled protocol ieee
  Root ID    Priority    24644
             Address     0019.56db.d900
             This bridge is the root
             Hello Time   1 sec  Max Age  7 sec  Forward Delay  5 sec

The IE solution is:

spanning-tree vlan 68 root primary diameter 3 hello-time 1

spanning-tree vlan

diameter net-diameter
 (Optional) Set the maximum number of switches between any two end stations. The range is 2 to 7.
 
hello-time seconds
 (Optional) Set the interval between hello bridge protocol data units (BPDUs) sent by the root switch configuration messages. The range is 1 to 10 seconds. 

sw2(config)#spanning-tree vlan 68 root prim dia 3 hello 1
sw2(config)#do sh sp vl 68

VLAN0068
  Spanning tree enabled protocol ieee
  Root ID    Priority    24644
             Address     0019.56db.d900
             This bridge is the root
             Hello Time   1 sec  Max Age  7 sec  Forward Delay  5 sec

1.7 EtherChannel

I did not understand this task at all.  The IE guide has no explanation either.  I understand the technologies involved but I could not figure out what the task was asking for.  😦

 

Blog at WordPress.com.