CCIE Pursuit Blog

April 11, 2008

Question Of The Day: 11 April, 2008

Filed under: Cisco,IOS — cciepursuit @ 8:59 am
Tags: , , , , , ,

Topic: IP Routing

Refer to the network diagram below (click for larger version).

Question of The Day Network Diagram

The network engineer wants to load balance traffic from r1 to r4’s user network (100.1.4.0/24). He has altered the Administrative Distance of the RIP routes on r1 to 90 so that they match the Administrative Distance of the EIGRP routes.

r1#sh ip route | e 100.
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 4 subnets
C 10.1.13.0 is directly connected, FastEthernet1/0
C 10.1.12.0 is directly connected, FastEthernet0/0
D 10.1.24.0 [90/30720] via 10.1.12.2, 06:48:57, FastEthernet0/0
R 10.1.34.0 [90/1] via 10.1.13.3, 00:00:16, FastEthernet1/0

r1#sh run | sec router
router eigrp 100
network 10.1.12.1 0.0.0.0
no auto-summary
router rip
version 2
passive-interface default
no passive-interface FastEthernet1/0
network 10.0.0.0
distance 90
no auto-summary

r4#sh run | sec router
router eigrp 100
network 10.1.24.4 0.0.0.0
network 100.1.4.4 0.0.0.0
no auto-summary
router rip
version 2
passive-interface default
no passive-interface FastEthernet1/0
network 10.0.0.0
network 100.0.0.0
no auto-summary

*The user network is being emulated by lo0 on r4.  It is being advertised by both EIGRP and RIP.

Will packets from r1 to 100.1.4.0/24 be load-balanced between r2 and r3? Why?

Click Here For The Answer


Yesterday’s Question

Question Of The Day: 10 April, 2008

Topic: Frame Relay Traffic Shaping

The network engineer in charge of r1 recently configured Frame Relay Traffic Shaping. The remote sites have complained that they are still getting too much traffic ingress on their Frame Relay connections to r1. You agree to look at his configuration:

map-class frame-relay FRTS
frame-relay cir 256000
frame-relay be 12880
frame-relay mincir 128000
frame-relay adaptive-shaping becn
!
interface Serial1/0
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
frame-relay class FRTS
frame-relay map ip 10.1.1.2 102 broadcast
frame-relay map ip 10.1.1.3 103 broadcast
no frame-relay inverse-arp

r1#sh frame map
Serial1/0 (up): ip 10.1.1.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active

What is the problem with this configuration?

Answer: You need to configure ‘frame-relay traffic-shaping’ under interface s1/0

The configuration above is correct expect that Frame Relay Traffic Shaping is not enabled on an interface until you configure ‘frame-relay traffic-shaping’

Before:
r1#sh traffic-shape s1/0
Traffic shaping not configured on Serial1/0

After:
r1(config)#int s1/0
r1(config-if)#frame-relay traffic-shaping
r1(config-if)#do sh traffic-shape s1/0

Interface Se1/0
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
103 256000 5610 256000 12880 125 4000 BECN
102 256000 5610 256000 12880 125 4000 BECN

Adaptive Frame Relay Traffic Shaping for Interface Congestion

frame-relay traffic-shaping

Advertisements

2 Comments »

  1. In regards to the question of the day: IP Routing

    I would say the answer would be No. The reason being is because R4 will advertise 100.0.0.0/8 out interface fa1/0 and EIGRP will advertise 100.1.4.0/24 out interface fa0/0. R2 and R3 will advertise both of these prefixes to R1. R1 will install both in the routing table as they are different prefixes. R1 will not load balance traffic over R2 and R3 for 100.1.4.0. Why? Because the router will first look in its routing table and determine that traffic destined to this networks should use the longest match route learned via EIGRP. However, if auto-summarization was not enabled on R4, then yes, traffic would be load balanced.

    I could be way off base here as I’m still learning (not near CCIE level) but this is what my answer would be.

    Comment by Ron — April 13, 2008 @ 9:40 pm | Reply

  2. @Ron – Good points. I forgot to mention in the question that auto-summary is disabled for both the RIP (version 2) and EIGRP domains. In this case r1 is receiving the 100.1.4.0/24 route from both RIP and EIGRP.

    Here are the 100.1.4.0 routes that r1 is receiving:

    From RIP (int f0/0 shutdown:
    r1#sh ip route 100.1.4.0
    Routing entry for 100.1.4.0/24
    Known via “rip”, distance 90, metric 2
    Redistributing via rip
    Last update from 10.1.13.3 on FastEthernet1/0, 00:00:03 ago
    Routing Descriptor Blocks:
    * 10.1.13.3, from 10.1.13.3, 00:00:03 ago, via FastEthernet1/0
    Route metric is 2, traffic share count is 1

    From EIGRP (int f1/0 shutdown):
    r1#sh ip route 100.1.4.0
    Routing entry for 100.1.4.0/24
    Known via “eigrp 100”, distance 90, metric 158720, type internal
    Redistributing via eigrp 100
    Last update from 10.1.12.2 on FastEthernet0/0, 00:00:16 ago
    Routing Descriptor Blocks:
    * 10.1.12.2, from 10.1.12.2, 00:00:16 ago, via FastEthernet0/0
    Route metric is 158720, traffic share count is 1
    Total delay is 5200 microseconds, minimum bandwidth is 100000 Kbit
    Reliability 255/255, minimum MTU 1500 bytes
    Loading 1/255, Hops 2

    Comment by cciepursuit — April 14, 2008 @ 8:21 am | Reply


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: