CCIE Pursuit Blog

April 6, 2008

Internetwork Expert Volume II: Lab 9 – Section 1

Bridging and Switching – 17 Points

“There are no faults in the initial configurations.”
“Do not alter the commands in the initial configurations.”

1.1 Trunking

One of the first things that you’ll notice in this lab is that there are routing protocols preconfigured.  BGP on sw1, EIGRP on sw3, and so on.  This looks like it will be an interesting lab.  🙂

I’m off to a rough start already.  The first task is a simple trunking task with the requirement of:

“For ease of administration refer to these trunks with the interface macro DOT-ONE-Q.”

I’m going to assume that “refer to” means “create a macro that completes this task.”  This is another “ask the proctor” moment.

Configuring Smartports Macros

The totality of my experience with switchport macros lies with creating ping scripts. 

sw1(config)#macro name DOT-ONE-Q
Enter macro commands one per line. End with the character ‘@’.
interface range fa0/13 – 15
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
@

sw1(config)#do sh run int fa0/13
interface FastEthernet0/13
end

Okay.  Let’s run this sucker:

sw1(config)#macro glob app DOT-ONE-Q
sw1(config)#do sh run int fa0/13
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate

end

Sweet!!!  Well maybe not:

sw1#sh run int fa0/14
interface FastEthernet0/14
end

For whatever reason the interface range did not take.  It only took the first interface.  Okay…there is no “minimal configuration” requirement so I took out the interface range command and explicitly configured each port:

sw1(config)#macro name DOT-ONE-Q
Enter macro commands one per line. End with the character ‘@’.
int fa0/13
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
int fa0/14
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
int fa0/15
switchport trunk encap dot
switchport mode trunk
switchport none
no shut
@

The IE solution uses:

define interface-range DOT-ONE-Q FastEthernet0/13 – 15

but then their macro explicitly configures each interface.  So what it the purpose of the above command?

define interface-range

1.2 Trunking

Weird.  sw4 is a 3550 yet:

interface FastEthernet0/19
 switchport mode dynamic auto <-auto?

Must have been thrown on in the initial configs.

Otherwise, this was a very basic EtherChannel configuration task.

1.3 Trunking

Fun trunking task. 

“All traffic sent over these trunk links should include a 32 bit tag.”

This threw me off at first.  ISL has a 24 byte tag and Dot1q has a 4 byte tag.  What the hell is a 32 byte tag?  Reading the requirement closer, I see 32 BIT no 32 byte.  Ah…32/8 = 4 bytes = Dot1q 🙂

Of course, I missed the second important part of that requirement: ALL TRAFFIC

By default dot1q does NOT tag the native VLAN so any traffic on the native VLAN will not have a 32 bit tag. 

vlan dot1q tag native

1.4 VLAN Assignments

Argh!!!  The dreaded “minimal VLAN configuration with all switches in VTP Transparent mode from the diagram” task.  :-0

I’m getting better at this (I completed the task successfully) but I am still VERY slow.

1.5 Spanning-Tree Filtering

spanning-tree guard

1.6 Spanning-Tree

I monkeyed around with this task trying to match the STP timers required by the task.  I finally gave up and went ahead and explicitly set the timers for VLAN 68.  This cost me the points as I needed to accomplish this task with minimal configuration:

sw2(config)#span vlan 68 hell 1
sw2(config)#span vlan 68 max 7
sw2(config)#span vlan 68 for 5
sw2(config)#do sh span vlan 68

VLAN0068
  Spanning tree enabled protocol ieee
  Root ID    Priority    24644
             Address     0019.56db.d900
             This bridge is the root
             Hello Time   1 sec  Max Age  7 sec  Forward Delay  5 sec

The IE solution is:

spanning-tree vlan 68 root primary diameter 3 hello-time 1

spanning-tree vlan

diameter net-diameter
 (Optional) Set the maximum number of switches between any two end stations. The range is 2 to 7.
 
hello-time seconds
 (Optional) Set the interval between hello bridge protocol data units (BPDUs) sent by the root switch configuration messages. The range is 1 to 10 seconds. 

sw2(config)#spanning-tree vlan 68 root prim dia 3 hello 1
sw2(config)#do sh sp vl 68

VLAN0068
  Spanning tree enabled protocol ieee
  Root ID    Priority    24644
             Address     0019.56db.d900
             This bridge is the root
             Hello Time   1 sec  Max Age  7 sec  Forward Delay  5 sec

1.7 EtherChannel

I did not understand this task at all.  The IE guide has no explanation either.  I understand the technologies involved but I could not figure out what the task was asking for.  😦

 

Advertisements

2 Comments »

  1. 1.6 Spanning-Tree is a funny task.
    After configuration, Show runn will show individual commands like you configured.
    And after a reload, there is simply no way anybody can know how the vlaues were configured, individually or with “minimum config”.
    I scrathed my head trying to understand, how in the hell would proctor or anyone know that a single line was issued not 3 separate lines:)
    As for Task 1.7, please do a write up if you understand it. 🙂

    Comment by Barooq — April 6, 2008 @ 10:14 am | Reply

  2. Hi,

    I’ve noticed the problems you’ve had applying smartport macro’s, I have created an article covering these in the past which can be accessed at http://www.configureterminal.com/newsletters/private/2007_05.html#3

    Feel free to unicast me with any questions

    Richard

    Comment by Richard @ Configureterminal.com — April 7, 2008 @ 6:18 am | Reply


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: