CCIE Pursuit Blog

July 14, 2009

Core Knowledge Question of the Day: 14 July 2009

Does an OSFP stub explicitly filter Type-4 LSAs, or is their absence in an OSPF stub area simply due to being unnecessary because the Type-5 LSAs have been filtered?

Highlight for answer: Actually, I don’t know the answer to this question.  I was thinking about it today.  In an OSFP stub area Type-5 LSAs are explicitly filtered.  There are no Type-4 LSAs present either.  I don’t know if they are explicitly filtered, or they are just never generated because the Type 5 LSA is filtered/never created?  It’s my understanding (possibly a misunderstanding) that the ASBR generates the Type-4 LSA, so…it must be explicity filtered at the ABR, right? <–This is WRONG! :-)

—-

Thank you for the comments (big ups to Ivan P, Zeeshan, and Pavel Sefanov).  I think that I have this cleared up in my head now:

The ABR generates the Type-4 LSA. If the area is configured as a stub area, the ABR filters the Type-5 LSAs(generated by the ASBR) and does not generate a Type-4 LSA. So, technically, an OSPF stub configuration only explicitly filters Type-5 LSAs, but it implicitly filters Type-4 LSAs as well as there is no need for the ABR to generate a Type-4 LSA.

So if you were to tell a co-worker that both Type-5 and Type-4 LSAs are filtered, you would be technically wrong.  :-(

Ivan Pepelnjak from Cisco IOS Hints and Tricks wrapped it up nicely:

To make it more explicit: the type-4 LSA is the glue that ties together a type-5 LSA originated by an out-of-area ASBR with the ABR flooding type-5 into the area. If there are no type-5 LSAs, type-4 LSAs are not needed (you will also not see them for ASBRs in the same area).

June 2, 2009

Core Knowledge Question of the Day: 02 June 2009

An OSPF virtual-link is a link to the backbone area through….

Highlight for answer: a nonbackbone(transit), non-stub area.

June 1, 2009

Core Knowledge Question of the Day: 01 June 2009

When configuring OSPF Fast Hello Packets, does the hello multiplier need to match on the entire segment?

Highlight for answer: Not as long as at least one hello packet is sent within the dead-interval (1 second).

April 30, 2009

Core Knowledge Question of the Day: 30 April 2009

Filed under: Cisco,Cisco Certification,IOS,OSPF,Question Of The Day — cciepursuit @ 4:00 am

Which of the OSPF stub areas available in IOS is a Cisco proprietary stub area?

Highlight for answer: The NSSA Totally Stub Area is a Cisco proprietary OSFP stub area.

April 2, 2009

Core Knowledge Question of the Day: 02 April 2009

Which OSPF area will int fa0/0 be assigned:

interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
ip ospf 100 area 12

Rack1R1(configr)#router ospf 100
Rack1R1(config-router)#network 10.1.12.1 0.0.0.0 area 21
Rack1R1(config-router)#network 10.1.12.1 255.255.255.255 area 2
Rack1R1(config-router)#network 10.1.12.0 0.0.0.255 area 3
Rack1R1(config-router)#network 10.1.12.0 255.255.255.0 area 4

Highlight for answer: Area 12

April 1, 2009

Core Knowledge Question of the Day: 01 April 2009

Which LSA type is flooded throughout the autonomous system by an Area Border Router and contains an AS Boundary Router address?

Highlight for answer: Type-4 LSA(ASBR Summary)

March 31, 2009

Core Knowledge Question of the Day: 31 March 2009

What type of OSPF area allows only LSA-types 1 and 2 as well as a single type-3 default route?

Highlight for anwer: Totally stubby area

March 30, 2009

Core Knowledge Question of the Day: 30 March 2009

Filed under: Cisco,Cisco Certification,OSPF,Question Of The Day — cciepursuit @ 9:27 am

An NSSA Area Border Router will do what before advertising a Type-7 LSA into a non-NSSA area?

Highlight for answer: Translate it to a Type-5 LSA

March 27, 2009

Core Knowledge Question of the Day: 27 March 2009

What is the multicast address that an OSPF device uses to communicate with the designated router?

Highlight for answer: 224.0.0.6

TIP: If you are allowed access to a command prompt during the open-ended questions and you want to verify your answer (or you know that the answer is 224.0.0.x but you forget what the last octet is)then you can always do an ‘nslookup 224.0.0.x’ and plug in values for the last octet.

Highlight below for some examples (from Linux but Windows will return the same/similar results):

1.0.0.224.in-addr.arpa    name = ALL-SYSTEMS.MCAST.NET.
2.0.0.224.in-addr.arpa    name = ALL-ROUTERS.MCAST.NET.

5.0.0.224.in-addr.arpa    name = OSPF-ALL.MCAST.NET.
6.0.0.224.in-addr.arpa    name = OSPF-DSIG.MCAST.NET.
9.0.0.224.in-addr.arpa    name = RIP2-ROUTERS.MCAST.NET.
10.0.0.224.in-addr.arpa    name = IGRP-ROUTERS.MCAST.NET.

March 24, 2009

Core Knowledge Question of the Day: 24 March 2009

What are the default OSPF hello-inverval and dead-interval for the OSFP broadcast network type?

Highlight for answer: 10 seconds for the hello-interval and 40 seconds for the dead-interval.

Next Page »

The Rubric Theme. Create a free website or blog at WordPress.com.

Follow

Get every new post delivered to your Inbox.

Join 113 other followers