CCIE Pursuit Blog

November 17, 2008

Cool Command 3: show ip ospf database database-summary

‘show ip ospf database’ is one of those commands that every CCIE candidate needs to know how to use as it can show you a ton of very good OSPF information.  There are a ton of options for this command:

r2#show ip ospf database ?
  adv-router        Advertising Router link states
  asbr-summary      ASBR summary link states
  database-summary  Summary of database
  external          External link states
  network           Network link states
  nssa-external     NSSA External link states
  opaque-area       Opaque Area link states
  opaque-as         Opaque AS link states
  opaque-link       Opaque Link-Local link states
  router            Router link states
  self-originate    Self-originated link states
  summary           Network summary link states
  |                 Output modifiers
  <cr>

I can’t believe that I’ve gotten this far and never used the “database-summary” option for this command. 

database-summary
 (Optional) Displays how many of each type of LSA for each area there are in the database, and the total.

Here’s the output of the command for an OSPF process with area 0 and three non-zero areas (note the difference in the LSA types in Area 0 versus the non-zero areas):

r1#show ip ospf database database-summary

            OSPF Router with ID (1.1.1.1) (Process ID 100)

Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   6        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
    Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0      

Area 100 database summary
  LSA Type      Count    Delete   Maxage
  Router        1        0        0      
  Network       0        0        0      
  Summary Net   8        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
    Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0      

Area 101 database summary
  LSA Type      Count    Delete   Maxage
  Router        1        0        0      
  Network       0        0        0      
  Summary Net   8        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
    Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0      

Area 102 database summary
  LSA Type      Count    Delete   Maxage
  Router        1        0        0      
  Network       0        0        0      
  Summary Net   8        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
    Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0      

Process 100 database summary
  LSA Type      Count    Delete   Maxage
  Router        5        0        0      
  Network       1        0        0      
  Summary Net   30       0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    0        0        0      
      Prefixes redistributed in Type-5  0
  Opaque AS     0        0        0      
  Total         36       0        0

As you can see this command shows a count of each type of LSA for each OSPF area (per process if you’re running multiple processes).  You can limit the output to a specific area (or process) with a grep command:

Show just the database-summary for area 0:

r2#show ip ospf database database-summary | sec Area 0
Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router        2        0        0      
  Network       1        0        0      
  Summary Net   6        0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
    Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Subtotal      9        0        0 

Show just the database-summary for Process 100:

r2#show ip ospf database database-summary | sec Process 100
Process 100 database summary
  LSA Type      Count    Delete   Maxage
  Router        5        0        0      
  Network       1        0        0      
  Summary Net   30       0        0      
  Summary ASBR  0        0        0      
  Type-7 Ext    0        0        0      
  Opaque Link   0        0        0      
  Opaque Area   0        0        0      
  Type-5 Ext    0        0        0      
      Prefixes redistributed in Type-5  0
  Opaque AS     0        0        0      
  Total         36       0        0

March 27, 2008

Cool Command 2: Verify Your BGP Regular Expressions

Here’s a great command for verifying (or just practicing) your BGP regular expression filters.  In the example below, I want to only see the routes where AS54 is the last AS in the AS path*.  I’m pretty sure that my regular expression is correct, but I want to verify it by running it against my BGP database.

Here’s the full BGP database:

r6(config)#do sh ip bgp | b Netw
   Network          Next Hop            Metric LocPrf Weight Path
*> 28.119.16.0/24   204.12.1.254             0             0 54 i
*> 28.119.17.0/24   204.12.1.254             0             0 54 i
*> 112.0.0.0        54.1.3.254               0             0 54 50 60 i
*> 113.0.0.0        54.1.3.254               0             0 54 50 60 i
*> 114.0.0.0        54.1.3.254               0             0 54 i
*> 115.0.0.0        54.1.3.254               0             0 54 i
*> 116.0.0.0        54.1.3.254               0             0 54 i
*> 117.0.0.0        54.1.3.254               0             0 54 i
*> 118.0.0.0        54.1.3.254               0             0 54 i
*> 119.0.0.0        54.1.3.254               0             0 54 i
*> 205.90.31.0      204.12.1.3                             0 200 254 ?
*> 220.20.3.0       204.12.1.3                             0 200 254 ?
*> 222.22.2.0       204.12.1.3                             0 200 254 ?

Here’s the results of filtering with ^54_ :

r6(config)#do sh ip bgp regex ^54_
BGP table version is 14, local router ID is 150.1.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 28.119.16.0/24   204.12.1.254             0             0 54 i
*> 28.119.17.0/24   204.12.1.254             0             0 54 i
*> 112.0.0.0        54.1.3.254               0             0 54 50 60 i
*> 113.0.0.0        54.1.3.254               0             0 54 50 60 i
*> 114.0.0.0        54.1.3.254               0             0 54 i
*> 115.0.0.0        54.1.3.254               0             0 54 i
*> 116.0.0.0        54.1.3.254               0             0 54 i
*> 117.0.0.0        54.1.3.254               0             0 54 i
*> 118.0.0.0        54.1.3.254               0             0 54 i
*> 119.0.0.0        54.1.3.254               0             0 54 i

show ip bgp regexp

*Thanks to apep for the correction.  See comment section for details.

March 24, 2008

Cool Command 1: Verify OSPF Authentication

Here’s a nice command to quickly verify that your OSPF authentication is enabled:

r5#sh ip os int | i proto|auth|Area
OSPF_VL0
is up, line protocol is up
  Internet Address 191.1.45.5/25, Area 0
  Message digest authentication enabled
Loopback0 is up, line protocol is up
  Internet Address 150.1.5.5/24, Area 0
Serial0/0 is up, line protocol is up
  Internet Address 191.1.125.5/24, Area 0
  Message digest authentication enabled
FastEthernet0/0
is up, line protocol is up
  Internet Address 191.1.5.5/24, Area 5
  Simple password authentication enabled
FastEthernet0/1.45
is up, line protocol is up
  Internet Address 191.1.45.5/25, Area 45
  Simple password authentication enabled
FastEthernet0/1.59
is up, line protocol is up
  Internet Address 191.1.59.5/24, Area 90
FastEthernet0/1.50 is up, line protocol is up
  Internet Address 191.1.50.5/24, Area 90

This command shows us all of the OSPF enabled interfaces, what area they are they are in, whether they are using authentication or not, and – if so – what type of authentication we are using.

For example, we can see that s0/0 is OSPF enabled, is in area 0, is running authentication, and the authentication type is md5.

ip ospf authentication

ip ospf authentication-key

ip ospf message-digest-key

area authentication  

show ip ospf interface

January 9, 2008

Using Regular Expressions With Show Commands

Here’s a nice article showing some interesting uses of regular expressions with show commands.  I’ve posted part of it below, you can read the rest here.   The article looks like it comes from OneTrain, but I couldn’t find it on their site.

*****Updated 10 January*****

David Bombal contacted me and provided the link to the original article (rather than the reposting in the forum):

Hi,

I am glad that you found my article to be useful. This is a copy of an article from my monthly newsletter.

You can find the original article here: http://www.configureterminal.com/newsletters/2.html

Please would you update your links to point to the original article?

Your readers will be able to access more information like this by registering on our website.

Regards,
David Bombal
CCIE #11023, CCSP, CCIP, CCSI, CCNP, CCDP, CCVP
http://www.ConfigureTerminal.com

I have updated the links to point to that article. 

Using the power of regular expressions with Show commands
By David Bombal

This is an advanced topic, so get your ready…

We have covered some basic regular expressions in our “Cool IOS Commands” EBook. Here I want to show you more complicated examples of how to use the power of regular expressions to filter output. This will allow the router to do the searching for text, rather than us doing it manually.

Regular expressions are used in many places in the IOS including BGP AS paths and Voice number translations. They are also used in other languages like Perl and TCL. Here however, we are going to concentrate on regular expressions with IOS show commands. We are going to use them to search for specific sets of strings.

A regular expression is a pattern (for example a phrase or a number) that can be used very effectively to filter output. Regular expressions are case-sensitive and allow for complex matching requirements.

I start with some simple examples so that you can learn each regular expression character individually and then we will combine them into complicated strings. As always with programming, there are many ways to do things, so use your imagination:

^ Regular Expression
Use this to look for text at the beginning of a string.

For Example: ^123 matches 1234, but not 01234 or 91234

On a router we can demonstrate this as follows: (without any regular expressions)

Router#show run | include ip
ip cef
no ip dhcp use vrf connected
ip dhcp pool ITS
option 150 ip 10.1.1.1
no ip domain lookup
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
ip address 192.168.10.1 255.255.255.0
ip address 192.168.11.1 255.255.255.0
ip address 192.168.12.1 255.255.255.0
ip address 192.168.13.1 255.255.255.0
ip address 192.168.14.1 255.255.255.0
<MORE>

However, if we use the following:
Router#show run | include ^ip

The output is:
Router#show run | include ^ip
ip cef
ip dhcp pool ITS
ip http server

Note – as expected, every line begins with “ip”, string we matched on
$ Regular Expression:
Use this to look for text at the end of a string

For Example123$ matches 0123, but not 1234

On a router we can demonstrate this as follows: (without any regular expressions)

Router#show run | include 1
Current configuration : 5174 bytes
! Last configuration change at 15:27:21 UTC Wed Jan 24 2007
! NVRAM config last updated at 14:25:01 UTC Wed Jan 24 2007
version 12.4
network 10.1.1.0 255.255.255.0
option 150 ip 10.1.1.1
default-router 10.1.1.1
source-address 10.1.1.1 port 5060
create profile sync 0002381328447096
voice register dn 1
number 1100
number 1101
voice register pool 1
id mac 0003.6B8B.174A
number 1 dn 1
codec g711ulaw
ip address 192.168.10.1 255.255.255.0
interface Loopback1
ip address 192.168.11.1 255.255.255.0
ip address 192.168.12.1 255.255.255.0
ip address 192.168.13.1 255.255.255.0

but if we change it to
Router#show run | include 1$

The output is:
Router#show run | include 1$
voice register dn 1
number 1101
voice register pool 1
number 1 dn 1
interface Loopback1
interface Loopback11
interface Loopback21
interface FastEthernet0/1
session target ipv4:10.1.1.1
session target ipv4:10.1.1.11
session target ipv4:10.1.1.21
session target ipv4:10.1.1.31
session target ipv4:10.1.1.41
session target ipv4:10.1.1.51
session target ipv4:10.1.1.61
number 1001
ephone 1
button 1:1

Note – as expected, every line ends “1”, string we matched on.

Read the rest here.

December 10, 2007

Quick QoS Tip

If you use the same name for all of your (MQC) QoS elements (class-map, policy-map, service-policy, etc), then you can easily see all of these elements with the section filter:

r3(config-cmap)#do sh run | sec FROM_FTP
class-map match-all FROM_FTP_SERVER
 match access-group name FROM_FTP_SERVER
policy-map FROM_FTP_SERVER
 class FROM_FTP_SERVER
  bandwidth 256
 service-policy output FROM_FTP_SERVER
ip access-list extended FROM_FTP_SERVER
 permit tcp host 132.1.33.33 132.1.6.0 0.0.0.255 eq ftp

November 10, 2007

More More More!!!

Another day, another indispensable command discovered.  This one is old, but I only just discovered a use for it today.  I had an issue with a router that melted.  I was able to get a basic config on it and dial into the sucker.  For some reason it was not seeing the ATM IMA card.  After having my site contact kick the hell out of it, it suddenly remembered that it did indeed have an IMA card  :-)  Unfortunately all of the ATM IMA configuration was blown away.  I knew that there was an older configuration saved to flash with the IMA configuration on it. [I could have also pulled a copy from CiscoWorks, but I was in a hurry and didn't want to deal with Java fighting with Windows].  I could see that the file was in flash, but I wanted to open it and pull out the configuration bits that I needed.  That’s when my co-worker suggested that I use “more“. 

I knew about this command only because it has been suggested by Cisco that instead of using “show start” you should use “more nvram:start”.  I’ve never adopted this because “sh start” is just too familiar and easy.  In this case, it was the perfect solution because “more” allows you to display the contents of a file. 

I saved an old configuration to flash as “lab”
r2#sh flash:
-#- –length– —–date/time—— path
1      3922109 Jul 1 2007 14:53:26 +00:00 c3550-i9k2l2q3-mz.121-14.EA1.bin
2         1541 Jan 28 2005 16:42:48 +00:00 sdmconfig-28xx.cfg
3      3885056 Jan 28 2005 16:43:08 +00:00 sdm.tar
4         1463 Jan 28 2005 16:43:22 +00:00 home.html
5       270848 Jan 28 2005 16:43:36 +00:00 home.tar
6        93095 Jan 28 2005 16:43:52 +00:00 attack-drop.sdf
7      1187840 Jan 28 2005 16:44:06 +00:00 ips.tar
8         1381 Nov 10 2007 16:18:32 +00:00 lab
9     41240024 May 26 2007 09:19:56 +00:00 c2800nm-adventerprisek9-mz.124-11.T2.bin

I want to see the old configuration for gi0/0:

r2#more flash:lab | sec GigabitEthernet0/0
interface GigabitEthernet0/0
 ip address 140.1.28.2 255.255.255.0
 duplex auto
 speed auto
r2#

Nice!!!  Now I want to make this old configuration my running configuration:

r2#copy flash:lab run
Destination filename [running-config]?

1381 bytes copied in 0.372 secs (3712 bytes/sec)

Let’s verify that the old config is on gi0/0 now:
r2#sh run int gi0/0
Building configuration…

Current configuration : 108 bytes
!
interface GigabitEthernet0/0
 ip address 140.1.28.2 255.255.255.0
 shutdown
 duplex auto
 speed auto
end

While I be sticking with “show” for the running and startup configurations, “more” is definitely a command that I will make use of quite a bit in the future.



Cisco Documentation

more

October 26, 2007

Automatically Upgrade Your IOS With Cisco IOS Auto-Upgrade Manager

David Davis has an interesting article about a new IOS feature to allow automatic IOS upgrades (not sure if you need a user/password to access the article or not).  I encourage you to read it.  Here’s the skinny on the Cisco IOS Auto-Upgrade Manager (AUM – like we need another acronym) from the horse’s mouth:

Cisco IOS® Auto-Upgrade Manager automates the process of upgrading Cisco IOS Software versions on Cisco® 1800, 2800, and 3800 Series Integrated Services Routers directly from the console without additional management software. Whether for a single device or multiple devices, Cisco IOS Auto-Upgrade Manager guides the user through the process of downloading the software to the router and scheduling the upgrade with easy-to-use, interactive mode prompts. More advanced users can take advantage of the Cisco IOS Auto-Upgrade Manager “single-line” command to initiate the process. Either way, Cisco IOS Auto-Upgrade Manager can help reduce the cost of upgrading systems by streamlining the process to perform Cisco IOS Software upgrades by engineers of varying skill levels.

As stated, this only works with 1800, 2800, and 3800 ISRs.  You also need to be running 12.4(15)T and later code.  It also has some prereqs:

  • The feature set must be Cisco IOS Advanced Security or higher (for HTTPS support).
  • The system being upgraded must have Internet connectivity that allows HTTPS (not blocked by a firewall).
  • The user must have a registered username and password on Cisco.com and have completed the Encryption Entitlement Form. Users are automatically prompted for this information the first time they select a strong cryptographic image for download directly in the Cisco Software Center; the form is also available at http://tools.cisco.com/legal/k9/controller/do/k9Check.x?eind=Y.
  • The SSL certificate for the Cisco IOS Auto-Upgrade Manager must be configured (refer to documentation for instructions).

And, as David Davis points out:

Of course, the irony of AUM is that you must first manually upgrade your routers before they can even support the new IOS.

I tried to find some documentation for the new commands (autoupgrade, upgrade automatic, upgrade automatic getversion) but I couldn’t find any details.  There was an example of the upgrade automatic getversion” command in the Cisco IOS Auto-Upgrade Manager documentation:

upgrade automatic getversion {cisco username username password pass image image|url} [at hh:mm|now|in hh:mm][disk-management auto|confirm|no]

This looks like an interesting feature and should work nicely with “warm reboot”.  For enterprises that have a number or devices that require IOS upgrades and do not use a software solution like CiscoWorks this may be a good option.  I wish that it was available on more platforms (specifically switches) but I’m sure that it will eventually work on more platforms.  I don’t like enabling https on Internet connected devices.  I might play with this next weekend to see how well it works on a 2800.

October 17, 2007

show interfaces transceiver properties

Occasionally I’ll stumble across a command that I’ve never seen before.  I recently had that experience with “show interfaces transceiver properties”.  The command is buried in the command guide under the voluminous “show interfaces” command:

(Optional) Display the physical properties of a CWDM1 or DWDM2 small form-factor (SFP) module interface. The keywords have these meanings:

•detail—(Optional) Display calibration properties, including high and low numbers and any alarm information.
•properties—(Optional) Display speed, duplex, and inline power settings on an interface.

While it’s supposed to be specific to SFP interfaces, it will work just fine with normal FastEthernet interfaces as well (I’m using a 3560 for this example):

sw1#show interfaces transceiver properties
Name : Fa0/1
Administrative Speed: auto
Administrative Duplex: auto
Administrative Auto-MDIX: on
Administrative Power Inline: N/A
Operational Speed: auto
Operational Duplex: auto
Operational Auto-MDIX: on

Name : Fa0/2
Administrative Speed: auto
Administrative Duplex: auto
Administrative Auto-MDIX: on
Administrative Power Inline: N/A
Operational Speed: auto
Operational Duplex: auto
Operational Auto-MDIX: on
—output truncated—

You can see that if we change some default settings on an interface, this command will show them:

interface FastEthernet0/3
 speed 10
 duplex half
 no mdix auto

sw1#show interfaces transceiver properties | b Fa0/3
Name : Fa0/3
Administrative Speed: 10
Administrative Duplex: half
Administrative Auto-MDIX: off
Administrative Power Inline: N/A
Operational Speed: 10
Operational Duplex: half
Operational Auto-MDIX: off

There is nothing really exciting in the output that I can’t get with “show interface fa0/3 status”, except for the MDIX information.  In a previous post, I wrote:

Note:The only command that I know of that will show the auto-MDIX state of an interface (other than looking at the running-configuration of the interface) is the rather verbose “show controllers ethernet-controller fax/x phy | include MDIX” command.

“show interfaces transceiver properties” accomplishes this as well and is slightly easier to type.  :-)

September 1, 2007

Ping Record Option

Filed under: Cisco,Cisco Certification,Cool Commands,IOS — cciepursuit @ 3:28 pm

Over at Cisco Notepad there is a nice post about the record ping option.  I haven’t used this option before.  From the Cisco documentation:

Record is a very useful option because it displays the address(es) of the hops (up to nine) the packet goes through.  

I generally use trace route in situations were I want to follow the path of a packet through the network, but the record option in ping does give one advantage over trace route: it shows you the path that the packet takes back to the source.

Take this simple network for instance:

Record Ping Network Diagram

We have two routes from r4 to the loopback on r5: via the serial link or through the Frame Relay cloud: 

r4#sh ip route 150.1.5.5
Routing entry for 150.1.5.0/24
  Known via “eigrp 100″, distance 90, metric 2306560, type internal
  Redistributing via eigrp 100
  Last update from 155.1.0.5 on Serial0/0, 00:11:19 ago
  Routing Descriptor Blocks:
  * 155.1.45.5, from 155.1.45.5, 00:11:19 ago, via Serial0/1
      Route metric is 2306560, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1536 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
    155.1.0.5, from 155.1.0.5, 00:11:19 ago, via Serial0/0
      Route metric is 2306560, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1536 Kbit
      Reliability 244/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

Let’s trace to 150.1.5.5:

r4#trace 150.1.5.5
Type escape sequence to abort.
Tracing the route to 150.1.5.5
  1 155.1.45.5 4 msec
    155.1.0.5 4 msec *

We can see that the trace packets take both routes.  Let’s try pinging the same address (2 packets) with the record option:

r4#ping
Protocol [ip]:
Target IP address: 150.1.5.5
Repeat count [5]: 2
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 150.1.5.5, timeout is 2 seconds:
Packet has IP options:  Total option bytes= 39, padded length=40
 Record route: <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)

Reply to request 0 (4 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (155.1.45.4) <-s0/1
   (150.1.5.5)  <-destination
   (155.1.45.5) <-return path
   (155.1.45.4) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Reply to request 1 (8 ms).  Received packet has options
 Total option bytes= 40, padded length=40
 Record route:
   (155.1.0.4) <-s0/0
   (150.1.5.5) <-destination
   (155.1.0.5) <-return path
   (155.1.0.4) <*>
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
   (0.0.0.0)
 End of list

Success rate is 100 percent (2/2), round-trip min/avg/max = 4/6/8 ms

In the real world, this option may not be of much use because of the 9 hop limit, plus the fact that most Internet addresses are not going to respond to the record option for security purposes.  But, in the lab, this can be a nice addition to your troubleshooting tool belt.


Cisco Documentation

Using the Extended ping and Extended traceroute Commands

August 19, 2007

Will Dynamips Kill Home Labs and Rack Rentals?

As I’ve spent more time using Dynamips, a thought crossed my mind:

Will Dynamips eventually end the need for home labs and rack rentals?

Dynamips seems to have a lot of momentum right now.  I have seen quite a few postings from CCIE candidates that are only using Dyanamips in order to lab up scenarios.  Dynamips has a lot of big advantages over the conventional rack rental/home lab.  It is free.  It is portable.  From what I’ve heard, you can lab up all kinds of different technologies (Frame Relay, ATM, MPLS, etc) and topologies.  The size of your Dynamips lab is only limited by the amount of CPU and RAM you can give it.  The vendors (so far just Internetwork Expert, but the rest of the Core Four can’t be too far behind) are starting to release workbooks geared towards Dynamips.  Why would anyone want to go through the headache and financial burden of building a home lab or spend money on rack rentals that tie you down to a specific window of time?

I think that Dyanamips will eventually become the most popular choice for doing labs for the CCIE (on multiple paths).  Does that mean the death bell will toll for rack rental companies and home labs?  No.  While I do think that we’re going to see some of the rack rental companies scale back, there will still be a need for real gear.  Dynamips cannot emulate a lot of the high-end switching features at this time (from what I understand, it never will).  This means that you’ll need to have access to actual Cisco switches in order to practice those skills.  Furthermore, even though Dynamips runs like a champ if you tweak it enough and give it enough resources, there are going to be candidates who simply won’t want to either spend the money to upgrade their systems (this will be less of an issue as time goes on and Moore’s law does its magic) or to take the time to tweak variables in the software. 

I also believe that the rack rental companies (especially the vendors’ racks) will still get business from candidates that are getting their employers to pay for their training.  Most (all?) of the vendors offer some combination of rack time packaged with their products.  If your employer is willing to pay for your rack rentals, why mess around with Dynamips?  One other advantage that the vendors have is that a good number of candidates are going to want to use their equipment because it matches the vendors’ lab topologies.  Also, there will be a sizable number of people (myself included) who will still want to use real gear, regardless of how closely Dynamips can emulate that gear.  If I run into a problem when I’m labbing on Dynamips, I note the issue and then lab it up on my rack to verify that it was not just a Dynamips bug.

My prediction is that Dynamips will increase in popularity as the program improves and as PC resources increase.  It’s going to put a dent in the rack rental business.  I think that the biggest casulty will be the home rack.  Why spend thousands on a rack that you’ll eventually try to sell back at the end of your studies, when you can have a portable lab with Dynamips (that you can augment with rack rental sessions).  One thing that is nearly certain, many more people are going to pursue CCIE certification because of Dynamips.  This software has effectively erased two big hurdles to CCIE certification: the cost and availability of Cisco network labs.  Finally, Dynamips is going to allow CCIE candidates to prepare for the lab much faster.   Candidates will not be tied down to specific windows of time (rack rentals) or the need to be connected to a home/work lab.  You can take your lab with you on your laptop.  This will maximize the amount of possible lab available to candidates.  More candidates with shorter study cycles will eventually lead to more CCIEs in the future.

Next Page »

The Rubric Theme. Create a free website or blog at WordPress.com.

Follow

Get every new post delivered to your Inbox.

Join 112 other followers