CCIE Pursuit Blog

May 29, 2007

Internetwork Expert Releases New R&S Product: Update

Filed under: CCIE Lab Workbooks,Training Materials — cciepursuit @ 8:43 pm

A couple of weeks ago I blogged about Internetwork Expert’s newest offering: video breakdowns of the solutions to their labs.  At the time I lamented about the cost of the videos:

The collection of videos is available for $1,595 or $1,295 if you already own the workbook.

It’s too bad that they aren’t releasing the solution videos as individual products.  It would be nice to drop $60 – $100 on a lab solution for a particularly troublesome lab rather than shelling out $1300 – $1600 on the whole set.

It looks like they took my advice.  :-) Okay, so that’s incredibly unlikely, but they are offering some less expensive options:

  •  
    • CCIE Routing and Switching 20 Lab Breakdowns Class-on-Demand (+ CCIE Routing and Switching Lab Workbook Volume II)-$1,595
    • CCIE Routing and Switching 20 Lab Breakdowns Class-on-Demand (upgrade for our existing customers who already purchased CCIE Routing and Switching Lab Workbook Volume II)-$1,295
    • Any 5 Lab Breakdowns Class-on-Demand- $495
    • Any single Lab Breakdown Class-on-Demand- $149

Link: CCIE Routing and Switching Lab Breakdowns Class-on-Demand (IEBD-RS-COD)

Cool OSPF/EIGRP Trick

Filed under: Cool Commands,IOS,Tech Tips — cciepursuit @ 11:15 am

So you’re labbing away and the scenario asks for an interface to be configured with an IP address in the 137.1.2.0/27 subnet.  You don’t reach for the IP calculator as you know that this will not be available on the lab, but instead you activate the part of your brain that speaks binary and come up with the correct configuration:

interface GigabitEthernet0/0
 description ->VLAN22 137.1.2.0/27
 ip address 137.1.2.2 255.255.255.224
 duplex auto
 speed auto
end

Now you need to advertise this network in OSPF or EIGRP.  Crap.  Now you need to convert the subnet mask to wildcard bits*.  This isn’t rocket science, but it is another opportunity for you to make a minor error that will bite you in the butt later.

*I know that the best method for doing this is to simply use the IP address of the interface with an all-zeros wildcard mask, but I’ll blog on that another time.

Thankfully, there is an IOS “trick” you can use with EIGRP (I assume IGRP as well) and OSPF.  Instead of entering a wildcard mask, just enter in the subnet mask (the same one you configured the interface with) and IOS will make the conversion for you:

Use the Subnet Mask Instead of the Wildcard Mask:
r2(config)#router os 100
r2(config-router)#net 137.1.2.2 255.255.255.224 area 0

IOS Makes the Conversion for you:
r2(config-router)#do sh run | sec ospf
router ospf 100
 log-adjacency-changes
 network 137.1.2.0 0.0.0.31 area 0

Frustration II: Cables and Passwords and Redistribution – Oh My!

Filed under: Cabling,Home Lab,IOS — cciepursuit @ 10:38 am

Since Saturday promised to be a very slow workday (beginning of a 3-day holiday weekend in the US) I decided that I would do some hardcore labbing.  In the end I put in 8 hours of lab time, but only completed two (small) labs. 

After a morning of frustration, I got started on some redistribution labs.  I finished two of the labs and was very happy with my results.  I’m finally getting my head around mutual redistribution and am pretty proficient with route-maps.  My configurations matched the answers and my show commands returned the expected results except for one subnet not getting redistributed from BGP into OSPF.  I poured through my configurations expecting to find an error there.  Everything looked good and there was no reason for this subnet not to be redistributed successfully while two other were unless I had mucked up a line in my access-list.  After double and triple-checking the configs I finally noticed that the FastEthernet port to the subnet was “up and down”.

That day I had finally added the last two devices to my lab by connecting two 3560 switches.  I made one of the new 3560s my sw1 to match the Internetwork Expert lab design.  I had assumed that the switches’ configurations were wiped clean.  Wrong.  When I consoled into the devices, I found that these were switches that were reclaimed when we bought out another company.  I tried every known combination of user/pass to get into the boxes.  No dice.  I decided to just go ahead and do a password recovery on the two devices using the following Cisco document:

Cisco 3560 – Recovering a Lost or Forgotten Password

This worked like a charm, except that the documentation states:

Step 4   Press the Mode button, and at the same time, reconnect the power cord to the switch.

You can release the Mode button a second or two after the LED above port 1 turns off. Several lines of information about the software appear with instructions, informing you if the password recovery procedure has been disabled or not.

The LED above port 1 never lit for me.  I discovered that once the System light stopped flashing, I could release the Mode button and be dropped into password recovery mode.

I successfully reset the enable secret password and wiped the two switches clean.  I still could not get the FastEthernet port to come up.  Finally, I swapped Ethernet cables with a known good cable and voila! the connection came up.  A bad cable!?!  Arrgghhhh!!!!

I was disappointed that I only managed to complete two short labs in 8 hours, but I am getting a lot of troubleshooting experience. :-)

May 26, 2007

Frustration (My Kingdom for a Flash Card Reader)

Filed under: Home Lab,IOS — cciepursuit @ 10:52 am

Getting started labbing has been a chore today.  I swapped out the 2620 that I was using for r2 because I could not load 12.4(10) Advanced Enterprise IOS code to it (insufficient RAM).  I want to have all of my routers (except the BBs) running 12.4 code so that I am running code that is current with the lab.  I made the 2520 a BB and retired the 2650 that was doing that job.  I put a 2851 in the stack to act as r2.  I love the 2800 series, but they are much taller (2 RU) and longer than the 2600 series.

Anyhoo…I wanted to upgrade the IOS on the 2851 to 12.4 (10) Advanced Enterprise.  I am using SolarWinds’ Free TFTP server on my laptop.  I downloaded the IOS from Cisco and then tried unsuccessfully to copy the image to flash.  After the third attempt I finally looked at the TFTP server logs and found the problem: “file too large for tftp protocol”.  I quick search on the web showed that this is an issue with SolarWinds’ TFTP Server.  I tried to install the recommended 3Com TFTP Serverand it failed.  I also tried to set up an FTP server on the laptop, but that failed as well.  The reason for the failures is that my work laptop has Cisco Security Agent running and it wreaks havoc with anything that it feels might be a security threat.  The end result is that I have wasted a good chunk of my day without getting any labs done or upgrading the IOS.  I going forward with the old code on the routers (not really a problem at this point) and will invest in a cheap compact flash card reader so that I can just add images to the removable compact flash on the 2851.  I can use the 2851 as a tftp for the other devices as well since it has plenty of room in flash to store IOS images.

May 24, 2007

Internetwork Experts to Rename Products

Filed under: CCIE Lab Workbooks,Training Materials — cciepursuit @ 3:07 pm

I found this on GroupStudy.com (my emphasis):

  • Subject: Re: IE LAB Workbookv4 VS Core Lab workbookv4
  • From: Brian Dennis <bdennis@xxxxxxxxxxxxxxxxxxxxxx>
  • Date: Mon, 14 May 2007 17:13:51 -0700 
  • The idea behind doing the Core Workbook labs is that since you can be pretty much guaranteed that you will get the core topics (FR, Switching, IGP, BGP, etc) you need to be able to count on all of their points and also be able to do them quickly.

    Ideally after you’ve done 8 or 10 of the IEWB-RS Workbook labs you would then do the Core Workbook labs to increase your speed and accuracy in the core technologies (FR, Switching, IGP, BGP, etc).  The Core Workbook labs have some of the toughest layer2/layer3 topologies of any of our products.

    Our marketing department has revamped all of our product names as part of a standardization process and we’ll be “officially” releasing them next week at Interop.  The Advanced Technology Labs will become IEWB-RS Vol I.  The IEWB-RS main workbook will become IEWB-RS Vol II and finally the Core Lab Workbook will become IEWB-RS Vol III.

    Brian Dennis, CCIE4 #2210 (R&S/ISP-Dial/Security/SP)

    LINK

    The Internetwork Expert website is already using the new naming convention.  This confused the hell out of me when I was looking at the Core Workbook last weekend.  I thought that they had released a new version of the Core Workbook but had skipped version 2 for some reason.  The above email sorts this out.

    May 23, 2007

    CCIE Routing and Switching Written Exam Update

    Filed under: CCIE Written — cciepursuit @ 6:24 pm

    Link 

    CCIE to Release Revised Routing and Switching Written Exam

    The CCIE Routing and Switching written exam (v3.0) will be released on June, 19, 2007 at all testing locations worldwide. The new version will replace the current version and will include previously untested topics, such as MPLS and IPv6. Candidates preparing for the Routing and Switching written exam on or after this date should refer to the CCIE RS for a detailed outline of topics that will be covered. Candidates planning take the exam BEFORE June 19th, should continue to refer to this blueprint.

    Passing the  Routing and Switching  written exam qualifies a candidate to schedule the CCIE  Routing and Switching  lab in addition to meeting recertification requirements where applicable. Find out more about scheduling CCIE exams.

    Paying Attention Will Save You Time and Points

    Filed under: Home Lab,IOS,Tech Tips — cciepursuit @ 5:49 pm

    Over the course of an 8 hour CCIE lab there will be plenty of opportunities to make stupid mistakes.  I am only starting to do simple labs which are nowhere near 8 hours in length, but I find myself making a lot of silly mistakes.  Hopefully I will make my mistakes now instead of in the CCIE lab.  Usually my mistakes result from “fat-fingering” such as the time I wasted an hour troubleshooting when I put in the wrong subnet mask.

    Today I was practicing mutual redistribution between RIP and OSPF.  I was reconfiguring a router and decided that it would be easier to blow away RIP with the “no router rip” command and rebuild it than it would be to strip out individual commands.

    Mutual Redistribution Between RIP and OSPF:
    router ospf 100
     log-adjacency-changes
     redistribute rip metric 69 subnets
     network 137.1.200.0 0.0.0.255 area 0
    !
    router rip
     redistribute ospf 100 metric 6
     version 2
     network 137.1.0.0
     no auto-summary

    Goodbye RIP:
    r1(config)#no router rip
    r1(config)#do sh run | b router
    router ospf 100
     log-adjacency-changes
     network 137.1.200.0 0.0.0.255 area 0

    More observant eyes than mine would have noticed that the redistibute RIP statement under the OSPF process was gone along with RIP process.  I was concentrating on making sure that the RIP process was gone.  After I rebuilt the RIP process, I had problems with route redistribution.

    Rebuild RIP:
    r1(config)#router rip
    r1(config-router)# redistribute ospf 100 metric 6
    r1(config-router)# version 2
    r1(config-router)# network 137.1.0.0
    r1(config-router)# no auto-summary
    r1(config-router)#do sh run | b router
    router ospf 100
     log-adjacency-changes
     network 137.1.200.0 0.0.0.255 area 0  <-redistribution statement still gone
    !
    router rip
     redistribute ospf 100 metric 6
     version 2
     network 137.1.0.0
     no auto-summary
    !

    After much head-scratching and troubleshooting, I eventually figured out that the problem was with the redistribution of RIP routes into OSPF.  It makes sense that IOS would remove references to redistributing RIP if RIP was removed.  My “shortcut” turned out to be anything but.

    May 22, 2007

    Cheapest. CCIE. Rack Rental. Ever!!!

    Filed under: CCIE Rack Rental — cciepursuit @ 10:57 am

    CiscoLabs.ca offers FULL DAY (that’s right, 24 hours) CCIE rack rentals for US$20.  This is by far the cheapest CCIE rack rental that I have come across.  The downside is that all the Routing and Switching lab time is booked through October. :-(

    A Great CCIE Blog

    Filed under: CCIE Blogs,CCIE Written,Training Materials — cciepursuit @ 10:46 am

    Ethan Banks has an outstanding blog chronicling his trek to pass the CCIE Routing and Switching written exam (he’s going to take it at Networkers in July).  I strongly suggest that you check it out.  His notes for each chapter of the CCIE Routing and Switching Official Exam Certification Guide (2nd Edition) are top-notch.  I can’t wait to read his blog once he starts working towards the lab.

    CCIE Candidate

    May 21, 2007

    Which Routing Protocol Process Am I Running?

    Filed under: IOS,Tech Tips — cciepursuit @ 7:57 pm

    So you’re in configuration mode and you’re ready to add a line to your BGP/OSPF/EIGRP process.  If you’re like me, you probably forgot which process/AS you’re running.  Was it “router eigrp 100″ or “router eigrp 10″?  Here is a quick command you can run from configuration mode to find the answer to that question: “do show ip protocols summary”

    r3#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    r3(config)#do sh ip proto sum
    Index Process Name
    0     connected
    1     static
    2     bgp 64563
    3     ospf 100
    4     eigrp 100

    Finding out the BGP AS is even easier.  Just type in “router bgp x” where x is any number.  The router will tell you the correct AS:

    r3(config)#router bgp 666
    BGP is already running; AS is 64563

    Command Reference:

    show ip protocols [summary]

    Next Page »

    The Rubric Theme Blog at WordPress.com.

    Follow

    Get every new post delivered to your Inbox.

    Join 109 other followers